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Introduction 

Besides the JobComposer, the ErgoSoft RIP system includes some tools to manage and 
control the production: 

JobCenter 
The JobCenter is used to monitor and manage all already printed (cut) jobs as well as 

all jobs that are still waiting for being printed (cut). 

Print and Cut Clients 
When you do not print or cut directly to the port the Print Client resp. Cut Client 

manages all jobs of a certain printer or cutter (configuration). 

This documentation will describe the JobCenter as well as the Print Clients and Cut Clients. 
For a description of the necessary configuration when running Print and Cut Clients on 
another computer as the JobComposer please refer to the manual part about Configuring 
Remote Clients. 
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JobCenter 

Introduction 

The JobCenter is used to monitor and manage all already printed (cut) jobs as well as all jobs 
that are still waiting for being printed (cut). 

The JobCenter is launched by pressing this icon in the modules list of the Standard 
toolbar in the JobComposer, by selecting menu Tools > Modules > JobCenter in the 
JobComposer, or by selecting JobCenter from the ErgoSoft RIP program group in 

the Windows program menu. 

 
The JobCenter Window 

The JobCenter window has the following components: 
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Toolbar 
The toolbar holds icons for fast access to job managing functions. 

Print and Cut Clients List 
The Print and Cut Clients list shows all active Print Clients and Cut Clients and allows 

setting them online and offline as well as loading the status monitor (when available) for 
checking the remaining ink. 

RIP Station List 
The RIP station list shows all active RIP Servers and allows setting them online and 

offline. 

Error Queue 
The error queue shows all jobs that could not be processed for any reason. 

Done Queue 
The done queue (job archive) shows all printed and cut jobs. The jobs can be archived 

automatically or manually to the hard disk or handled using the job managing functions (see 
below). 

Contour Cutting Queue 
The contour cutting queue shows all jobs that are waiting for a Cut Client to send 

them to a cutting plotter for contour cutting. The jobs can be handled using the job manag-
ing functions (see below). 

Printing Queue 
The printing queue shows all jobs that are waiting for a Print Client to send them to a 

printer. The jobs can be handled using the job managing functions (see below). 

Ripping Queue 
The ripping queue shows all jobs that are waiting to be rasterized and ripped. The jobs 

can be handled using the job managing functions (see below). 

Suspended Jobs Queue 
The suspended jobs queue shows all jobs that are waiting to be rasterized and ripped 

and have been set to be suspended. As soon as the suspension is removed the job is moved 
to the ripping queue. 

Jobs in the Suspended Jobs Queue can be re-loaded into the JobComposer and mod-
ified before they are sent to the RIP Server. This is done by using the command Edit Job 
from the Job context menu. 

Job Information 
The job information window lists some information about the job such as the job size, 

the used print environment, the number of copies, the creation date and more. 

Job Preview 
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Section Divider 

List Header 

Column Divider 

 
Configuration 

Configuring the Layout 

1) Sizes of the window sections: 
 The dividers between the different sections can be moved using the mouse. This allows 

you to design the JobCenter window according to your preferences. 
 
2) Designing the lists: 

 The width of the columns can be changed for each list separately by moving the col-
umn dividers with the mouse. 

 Columns can be removed by clicking with the right mouse button on the column 
name and selecting Remove Column. 

 Columns can be added by clicking with the right mouse button on an empty space in 
the list header and selecting Add Column. Then, select the appropriate column from 
the list. 

 
Automatically Deleting and Archiving Done Jobs 

The automatic job deletion and archiving function is started each time the JobCenter is 
loaded. It automatically deletes processed jobs or moves them to the archive folder. 

Launch the function 
by selecting menu 

File > Settings > Delete 
Done Jobs. 
 

The automatic job 
deletion should not 

be activated when you 
want to archive just a few 
jobs. In this case, the 
needed jobs can be archived manually (see below) before the jobs are removed manually 
from the JobCenter. 
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Instead of just deleting done jobs they can be archived in the archive for later re-use: 
they can be imported in the JobComposer (command File > Import from Archive) or 

restored in the JobCenter (see below). 
Ripped data are only available for being archived when the ripped data are kept after 

printing (see the manual part about printing) or when the job has been ripped to a Print 
Client and not yet been sent to the printer. 

Please note that archiving including images and especially ripped data requires a lot of 
disk space. 

The default archive folder can be changed to any folder you might want to include in 
your standard backup procedure. 

 
Default Settings for Dispatching Jobs 

The JobCenter allows specifying the default configuration for Print Clients for dispatching 
jobs. 

Launch the function 
by selecting menu 

File > Settings > Dispatch 
Print Jobs. 
 

The Print Client 
offers the possibili-

ty to check whether the 
media size and/or the 
media type of the print 
jobs match the settings in the Print Client in order to prevent jobs being printed on the 
wrong media (size). 

The default setting for all Print Clients can be changed in the Print Client itself. 
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Job Managing Functions 

The following functions allow managing the jobs. Please note that with active Print Clients 
and/or Cut Clients the jobs in the corresponding queues should be controlled in the Print 
Clients resp. Cut Clients and not in the JobCenter. 

 
Cancel Printing 

When the current printing process is being canceled, the job is marked as sus-
pended so that the complete printing process can be restarted by removing the 
suspension. 

The function is available in the Contour Cutting Queue, the Printing Queue, and the Ripping 
Queue. 

 
Deleting Job 

Jobs are logged in the JobCenter until they are automatically deleted/archived or 
deleted manually. Delete a job when you do not use it any more in the JobCenter. 
The function is available in the Job Archive, the Contour Cutting Queue, the Printing 

Queue, the Ripping Queue, and the Suspended Jobs Queue. 

 
Pausing Job 

Jobs can be paused so that they are not ripped, printed, or cut immediately but can 
be started manually after some time. To restart a paused (suspended) job, just re-
move the suspension. 

The function is available in the Job Archive, the Contour Cutting Queue, the Printing Queue, 
the Ripping Queue, and the Suspended Jobs Queue. 

 
Reprinting Job 

When a job is reprinted it is ripped again using the original settings – except when 
the ripped data are available. Please note that the images as well as the print envi-
ronment still must exist and must not be changed after the creation of the job. 

The function is available in the Job Archive. 
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Changing the Job Order 

The priority for jobs that wait to be ripped, printed, or cut can be raised or 
lowered. That means that the selected job is moved up or down in the list 
and thus, processed sooner or later. 

The functions are available in the Contour Cutting Queue, the Printing Queue, and the Rip-
ping Queue. 

 
Checking Production Data 

This function allows obtaining and exporting the information about used media, ink, and time 
as well as to obtain the production costs. 

The prices for media and ink 
are entered in the print en-
vironment on the General 
resp. Ink Cost tab. The costs 
of the ripping and printing 
time is entered in the printer 
setup (e.g. on the Printer tab 
in the print environment). 

For more information on 
production costs please 
refer to the manual part 
about Special Production Tools. 

The function is launched by selecting Production Data from the Job context menu. It is avail-
able in the Job Archive, the Contour Cutting Queue, the Printing Queue, and the Ripping 
Queue. 
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Modifying Job Properties 

The job properties allow checking some information about the job, changing some 
settings for later reprint as well as offering two different log files. 

Dialog part Job holds 
some basic informa-

tion about the job and al-
lows entering some infor-
mation about the job. 

When the Print Client is 
used for printing, the num-
ber of Copies can be 
changed as long as the 
printing process is not fi-
nished. 

For jobs in the Job 
Archive, the media 

field shows the selected 
media for printing. For jobs 
in the Queues the media field allows selecting a media. 

Keeping the RIP data allows archiving the job with the RIP data and reprinting the job 
without having to re-rip it. To save disk space the ripped data can be deleted when they 

are no longer used. 

The Exception button offers some functions that help in solving problems with devices 
(see chapter “Solving Problems with Devices”). 

The Journal logs all information that has been shown in the RIP Server for the selected 
job. The Production buttons shows dialog with information about production data. 

The function is available in the Job Archive, the Contour Cutting Queue, the Printing Queue, 
the Ripping Queue, and the Suspended Jobs Queue. 
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Printing Job Information 

Often, detailed information about a job is not only needed in the JobCenter but should be 
printed with a standard office printer or saved for the administration. The Job Ticket allows 
displaying detailed information about the current job in the default web browser in which it 
can be printed. 

Job Tickets are launched by selecting JobTicket from the Job context menu. They are saved 
automatically in the folder that is specified in the menu File > Settings > JobTickets. 

The function is available in the Job Archive, the Contour Cutting Queue, and the Printing 
Queue. 

 
Archiving Jobs 

In addition to or instead of the automatic archiving of jobs, jobs may be archived manually. 
For more information about the available options please refer to chapter “Automatically De-
leting and Archiving Done Jobs”. 

The function is launched by selecting Archive from the Job context menu. It is available in the 
Job Archive, the Contour Cutting Queue, the Printing Queue, the Ripping Queue, and the 
Suspended Jobs Queue. 

 
Reloading Archived Jobs 

Archived jobs cannot be only imported into the JobComposer but also just reloaded into the 
JobCenter in order to manage them just like any other job. 

The function is launched by selecting menu File > Restore. 
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Searching for Production Information 

The production data for all jobs are saved in the production database. Thus, this information 
is available no matter whether the job is still in the Job Archive of the JobCenter, archived, or 
deleted. 

Launch the function 
by selecting menu 

File > Production Data-
base. 
 

Specify the para-
meters for the 

search. 
View Result lists all jobs 
that meet the entered 
requirements as a list of 
production data. 

 
Controlling Devices 

The JobComposer and the RIP Server can be started in the JobCenter. The Print Clients 
and Cut Clients can be started as well as new Print Clients and Cut Clients can be set up. 

Please note that the icon for the Job Composer may look different 
depending on the product you are using. 

The RIP Server as well as all active Print Clients and Cut Clients can be set to online and 
offline in the JobCenter. This function is available in the Print and Cut Client List and the RIP 
Server List. 
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Solving Problems with Devices 

Reprinting Defective Copies 

Copies of a job can be reprinted without influencing the production data of this job. 
This is necessary when e.g. the printer run out of ink and the correct production 
data is needed. 

 
The Exception button in the 
job properties dialog offers 
the needed function: 

Reduce the number of 
printed copies by the num-
ber of the copies you have 
to reprint and close the di-
alog with OK. 

The function is available in 
the Job Archive, the Contour 
Cutting Queue, the Printing 
Queue, the Ripping Queue, 
and the Suspended Jobs 
Queue. 
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RIP Server Crash While Ripping 

When the RIP Server should crash during ripping (e.g. because of a printer prob-
lem) the currently processed job in the Ripping Queue is still waiting that ripping 
will be continued. 

The Exception button in the 
job properties dialog offers 
the needed function to reset 
this job: 

Click on the Reset to Wait-
ing button. After having 
prompted to acknowledge 
the reset the ripping 
process is aborted and the 
job is paused. It can be res-
tarted any time later. 
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Print and Cut Clients 

Introduction 

When you do not print or cut directly to the port the Print Client resp. Cut Client is 
used to capture the ripped data for easier control of the printer or cutter. It com-
municates with the Job Server that is visualized in the JobCenter. 

 Using the Print Client resp. Cut Client, several workstations may send print (or cut) jobs 
to a central network printer (or cutter) at the same time. The Print Client resp. Cut Client 
will print (or cut) the jobs one after the other. 
 

 When printing several copies of a job, time is saved by using the Print Client: The Ergo-
Soft RIP needs only to rip and print a single copy of the job; the Print Client prints the 
other copies independently. 

The Print Client resp. Cut Client is launched by selecting the wanted Print Client / Cut 
Client from the list in the Standard toolbar in the JobComposer, by selecting the wanted 
Print Client / Cut Client from the list after having selected menu Tools > Print Clients resp. 
Tools > Cut Clients in the JobComposer, or by selecting the wanted Print Client / Cut Client 
in the JobCenter. 

 
Setting up a Print Client / Cut Client 

Before a Print Client or Cut Client can be used it has to be set up. Launch the 
Print/Cut Client setup launched by pressing the displayed icon in the Print Envi-
ronment reps. Cut Environment toolbar in the JobComposer, by selecting menu 

Tools > Print Clients resp. Tools > Cut Clients in the JobComposer, or by selecting Setup in 
the Print & Cut Client list in the JobCenter. 

Specify whether you want to create a Print 
Client or a Cut Client. 

 
Select the printer or cutter for which you 
want to create a Print Client / Cut Client. 

Click on the Edit button to edit the printer/cutter 
configuration. 
For more information please refer to the descrip-
tion of the Printer and Port tab in the manual 
part about Print Environments. 
 

Closing the dialog box with OK will create 
(or modify) a shortcut for the Print Client / 

Cut Client in the Print/Cut Client-List in the JobCenter as well as launch the Print Client / 
Cut Client. 
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Configuring a Print Client / Cut Client 

When the Print Client / Cut Client is set up and launched it can be configured. The available 
options depend on the state in which the Print Client / Cut Client is: 

The Print Client / Cut 
Client can be set to Online, 

Manual Start, and Offline. These 
commands are also available in 
the Operation menu items Start 
manually and Offline which tog-
gles between online and offline. 
 

As long as the Print Client / 
Cut Client is set to offline, 

the port can be modified for the 
current Print/Cut Client task 
without having any effect on the 
printer or cutter settings.  
In addition, the status monitor can 
be selected and its update interval 
can be set. 

As long as the Print Client / Cut Client is set to offline, the media can be selected and 
the size of the media can be entered. Please note that only jobs are printed that are 

smaller than the selected media size. 
Also the pre-settings for the media size/type checking that are configured in the JobCenter 
can be changed for the current Print Client / Cut Client. 

As long as the Print Client / Cut Client is set to offline, maintenance jobs can be set 
up. For more information please refer to chapter “Sending Maintenance Jobs” below. 

As long as the Print Client / 
Cut Client is set to offline, 

menu Operation > Options offer 
some settings for automatic star-
tup. 

The View menu offers to 
show the status monitor 

when one have been configured in 
the port configuration dialog in 
the Print Client / Cut Client or in the printer settings. 
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Sending Data to a Print Client / Cut Client 

Printing or cutting to a Print Client / Cut Client is done automatically when the follow-
ing requirements are met: 

1) There is a spool folder set in the printer/cutter configuration (see the description of the 
Printer and Port tab in the manual part about Print Environments). 

2) The box Skip PrintClient (Print directly to port) is not checked in the printing dialog 
(see the manual part about Printing). 

 
When Operation > Check Printer Status is activated, the Print 
Client / Cut Client will not send data to the printer / cutter 

before the printer / cutter requests for new data. This function can 
be used to e.g. avoid problems in printing several copies when the 
printer cannot handle data of the next copy until the current one is 
completely printed. 

Please note that this functionality must also be supported by 
the printer / cutter in order to work properly. 
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Controlling the Print Client / Cut Client 

The Print Client / Cut Client window has the following components: 

Operation mode 
These buttons allow setting the Print Client / Cut Client to online, start manually, or 

offline. 

Operation state 
Shows what the Print Client / Cut Client is currently doing. 

Port settings 
In offline mode, this button allows checking the port settings and activating or deacti-

vating a status monitor. 

Cancel printing 
The printing of the current job can be canceled. 

Maintenance Jobs 
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In offline mode, maintenance jobs can be configured. 

Job information / Media settings 
In offline mode, the media check of the Print Client can be configured. In manual 

mode or online mode, (progress) information on the currently loaded / produced job is dis-
played. 

Print Queue Monitor 
The available functions are described in chapter “The JobCenter Window” above. 

Error Queue 

Job Archive 

Printing Queue 

Ripping Queue 

Job Information 

Job Preview 

Status Monitor 

 
Printing Jobs Automatically 

When the Print Client is set to online, the next job waiting in the Printing Queue is automati-
cally sent to the printer when it meets the media requirements set in the Print Client. 
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Starting Jobs Manually 

Using the Print Client in manual start mode is useful when e.g. the printer has to be 
checked before each print job or some job settings need modification before printing. 

When the Print Client is set to 
start manually, the next job to 

be printed is loaded. Information about 
this job is displayed below as well as in 
the Job Information and Preview win-
dows. 

Clicking the Start button will 
start sending the job to the prin-

ter. 

Depending on the used print 
driver (basic print environment), 

the button Change is activated allow-
ing you to modify some printer set-
tings configured in the print environ-
ment tab Device Options (such as print quality, print speed, heater settings, etc.) before the 
printout is started. 

 
Cutting Jobs 

For special information about cutting jobs using Cut Clients please refer to the manual part 
about Cutting with ErgoSoft RIPs. 
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Configuring the Total Ink Consumption 

This function allows correcting the amount of the used ink by the pro rata amount of ink 
needed for cleaning, changing cartridges, etc. 

 Launch menu Operation > Ink Consump-
tion. Please note that you have to set up 
the Print Client with an appropriate sta-
tus monitor before you can launch this 
function. 

 When changing the cartridge or refilling 
the ink system enter the Start ink level 
for each ink. This is written automatically 
into the database. The observation pe-
riod is started. 

 To end the observation period and cal-
culate the correction factor, enter the 
End ink level (e.g. remaining ink in your cartridge or ink system). 

 The correction factor is automatically calculated from the ink consumption information in 
the jobs during the observation period and the information about the spent ink in this di-
alog. 

 The correction factor can also be entered manually when it is known. 
 When a correction factor is available it is automatically used to correct the production data 

of new jobs. It is not used for jobs printed before. 
 Please note that the procedure for retrieving the correction factor (or manually entering 

the correction factor) must be done for each ink. 
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Sending Maintenance Jobs 

Some workflow requires that at certain intervals special maintenance jobs are sent to the 
printer. The ErgoSoft RIPs offer the possibility to load and configure maintenance jobs. 

Set the Print Client to Of-
fline. 

 
Click the Maintenance Job 
button to load a list with 

already configured maintenance 
jobs. 
 

Use the buttons to manage 
already set up maintenance 

jobs as well as to create new maintenance jobs. 
Configure the interval for automatic job 

processing according to your needs. 

Click the Send Now button to manually 
launch the selected maintenance job and 

process it immediately. 

There are some maintenance jobs delivered with the ErgoSoft RIP. Please contact your prin-
ter dealer for more maintenance jobs. 
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Running the Print Client / Cut Client without JobQueueServer 

Normally, the JobQueueServer captures the print job from the JobComposer and communi-
cates with the JobCenter and the Print Client / Cut Client. When the JobQueueServer is 
not available for any reason, the Print Client / Cut Client offers the possibility to send jobs 
from the spool folder to the printer/cutter: 

Set the Print Client / Cut Client 
to No-Server-Mode. 

The Print Queue offers limited 
access to jobs still waiting to be 

printed/cut. The buttons for managing 
jobs in the toolbar are disabled but 
some functions are available in the Job 
context menu. 

Reprinting a job is done by selecting 
Reprint from the Job context menu 
and selecting the number of copies. 
When closing the dialog with OK, the 
job is automatically sent to the Print 
Queue. 

The Print Client / Cut Client works in all modes as described above; there is no differ-
ent on the basic operating functions between Server-Mode and No-Server-Mode. 
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